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My Best Friend

In this program you can work on two kinds of projects:

Cartoon strips: You can choose to work with complete cartoon strips from the Cartoon Strip Library and write 
text for them.

Cartoon pictures: Or you can make your own cartoon strips using cartoon pictures from the Cartoon Library and 
write text for them.



How do you begin?

Cartoon Strips

Click on the   Cartoon Strips   menu and choose a category  
Open/close the workspace
Text Containers
Writing in text containers

Cartoon Pictures

Click on the   Cartoon Pictures   menu      
Open/close the workspace
Cartoon Library
Text containers
Writing in text containers

See also: Workspace Options 



Choosing a category and cartoon strip

1. Click on the Cartoon Strips menu and choose one of the categories (Sports, Home Life, Leisure, 
School).

2. Cartoon strips in that category appear on the screen.    

3. Click on a cartoon strip with the mouse and confirm your choice by clicking on the OK button at the 
bottom of the screen or double clicking on the strip.

4. My Best Friend opens the Cartoon Strips workshop with the comic strip you chose ready for you.



Opening and Closing the Workspace

Open the workspace: Click on the maximise button  in the upper right corner of the frame that you want to work 
on, or double click anywhere in the frame. You can also click on the frame with a text-container-
cursor. The workspace then opens automatically.

Close the workspace: Click on the minimise button  in the upper right corner of the workspace.



Picking Up Text Containers
 
The text container buttons are to the right of the comic strip. 

If you are working in the Cartoon Picture Workshop, you have to click on the Text    button at the bottom right of the screen 
before doing the following to pick up Text Containers:

1. You pick up a text container by clicking once on it and moving the cursor off the text container buttons.

The cursor's shape changes into the appropriate text container.

Note: If the cursor's shape did not change, you probably clicked twice, and the second click put the container 
down again.

2. Before you attach a talk- or thought-text container to a picture, you can rotate its tail by pressing the right 
mouse button. You cannot rotate the strip container.

3. To attach a text container to a frame, click with the container cursor anywhere on the frame. Talk and thought 
containers will stick wherever the cursor is on the frame when you click, but strip containers always zip to the 
very top or very bottom of the frame.

If you change your mind about a text container after you pick it up, you can get rid of it by clicking anywhere 
off of the comic strip frames. You get back the regular cursor.

See also:    Getting Text Containers or the Cartoon Library



Writing in a Text Container

You have to activate a text container in the workspace before you can write in it. 

1. You activate a text container by clicking on it.

2. A blinking cursor and frame inside the text container show that it is active. You then can type up to 256 
characters.

3. The text container will change shape depending on how much text you type.



Opening the Cartoon Picture Workshop

From the main menu click on Cartoon Pictures to open the Cartoon Picture Workshop.



Cartoon Library

1. The Cartoon Library is in the window on the right of the screen. If you are working in the Text Containers 
part of the Cartoon Pictures Workshop you have to click on the Cartoons button at the bottom right of the 
screen get the Cartoon Library.

2. The Library menu offers the following options: Backgrounds, People, Animals, Plants, Things.

3. You choose a picture by clicking on it.

4. To see how big the picture is before placing it in a frame, click on it with the right mouse button.

5. To place the picture in a frame, move the cursor over it and click.

See also:    Getting Text Containers or the Cartoon Library



Menu

The menu changes depending on where you are working.

The Main Menu:
--------------------------------------------------------------------------------------------------
 File Cartoon Strips Cartoon Pictures Help
--------------------------------------------------------------------------------------------------
    Open... Sports Contents
    Options... Home Life Search for Help on...
    Quit Leisure About Help

School About...

Cartoon Strip Menu:
---------------------------------------------------------------------------------------------------------
    File Export Text Container New Strip Help
---------------------------------------------------------------------------------------------------------
    Open... Windows Application Rotate Sports Contents
    Save Launch... Delete Home Life Search for Help on...
    Save As... Undo Leisure About Help
    Print... School About...
    Print Setup...
    Close
    Quit

Cartoon Workshop Menu:
-----------------------------------------------------------------------------------------------
    File Export/Edit Cartoon Edit Help
-----------------------------------------------------------------------------------------------
    Open... Windows Application Send to Back Contents
    Save Launch... Flip Vertical Search for Help on...
    Save As... Switch Positions... Flip Horizontal About Help
    Print... Text/Cartoons Make Bigger About...
    Print Setup... Make Smaller
    Close Rotate text container
    Quit Delete

Undo
    

In the Cartoon Library Menu you can have My Best Friend display categories of cartoon pictures or a palette of colours:

Cartoon Library Menu:
------------------------------------------------------------------------------------------------
Backgrounds People Animals Plants Things
------------------------------------------------------------------------------------------------
Scenes Boy Pig
Colours... Girl Others 

Others 



Open (File Menu)

Lets you retrieve a PIG-file that previously has been saved.

To open a file:

1. Click on the File menu and select Open

2. Choose a drive from the list Drives.

3. Choose a directory from the list Directories.

4. Type the name of the file or click on it from the list File Name.

5. Choose OK.



Save (File Menu)

Saves the file that you are working on under the name given it with the command Save As...    If the file has not been saved
before, you are asked to type a name for it and choose a disk directory just as with Save As...



Save As (File Menu)

Save As... saves a new or existing file under a new name.

To save a file under a new name:

1. Click on the File menu and select Save As

2. Choose a drive from the list Drives.

3. Choose a directory from the list Directories.

4. Write a new file name or choose an old PIG-file that may be written over.

5. Choose OK.

6. If the file already exists, you will be asked to confirm that you want the old file written over.



Print (File Menu)

Sends what you are working on to a printer. This option is available in both the Cartoon Strip and the Cartoon Picture 
Workshops.

If a workspace is open, only the cartoon in it is sent to the printer; otherwise, all four cartoons on the screen are sent for 
printing.

To print a cartoon:

1. Click on the File menu and select Print.

2. Type a title, if you want one, where it says Title.

3. Choose whether the picture will be printed as Colour/Grey Scale or as Outlines.

4. If you want the picture to be smaller than its normal size (100 %), type a number less than 100 (but at 
least 1) where it says Size.

5. Choose OK.



Printer Setup (File Menu)

Here you select a printer, page orientation, paper size and other print-related options.

This option is available in both the Cartoon Strip and the Cartoon Picture Workshops.

To change a printer setup:

1. Click on the File menu and select Printer Setup

2. Choose a printer from the list of installed printers.

3. Select a page orientation in Orientation.

4. Choose a paper size and source in Paper.

5. Click on Options if further printer adjustments are necessary.

6. Choose OK to confirm the selections.



Options (File Menu)

Tells My Best Friend    the drive and directory to use when the Open..., Save or Save As... commands are chosen.

You can choose Options... only when both workshops, Cartoon Strips and Cartoon Pictures are closed.

To change file options:

1. Click on the File menu and select Options.

2. Choose a drive and/or a directory from the list.    (Note: you cannot choose a directory from the a:- or 
b:-drive.)

3. Choose OK to confirm your selection.

If the directory has been set to the a:- or b:-drive and the drives are open when you choose Open or Save, My Best Friend  
automatically switches to the drive and directory on the hard disk where the program is.



Close (File Menu)

Closes a workshop, Cartoon Strips or Cartoon Pictures, and returns My Best Friend to the Main Menu.

The Close button is on the bottom right of the screen.

If the file has not been saved since changes were made, you are asked whether My Best Friend should save the file.



Quit (File Menu)

Closes down My Best Friend. If an open file has not been saved since changes were made to it, you are asked whether My
Best Friend should save the file.



Colour Background (Cartoon Picture Workshop Menu, Backgrounds)

Opens a colour dialogue. You can choose or mix a background colour to use for the cartoon you are making.

To choose or mix a background colour:

1. Choose Colours... under the Backgrounds menu.

2. Select a pre-mixed colour from the basic colours library by clicking on one, 

or

mix a new colour by clicking somewhere in the colour blending box to place the colour cross. Then, 
click in the colour column to lighten or darken the colour to suit you. You see the result in the 
Colour/Solid boxes.

3. Add the new colour to the Custom Colours by clicking on the Add to Custom Colours-button.

4. Clicking on OK confirms the colour.

5. Your cursor changes to a paint pot. When you place it over a frame and click with the left mouse 
button, My Best Friend paints the frame with the colour you chose.

6. If you change your mind, you can get rid of the paint pot cursor by moving it anywhere off of the frames
and clicking.



Switch Positions (Cartoon Picture Workshop, Cartoon Edit Menu)

Switches the positions of two of the four frames in the cartoon strip you are making. You can choose this option only when 
the workspace is closed.

To switch the positions of two frames:

1. Click on the Cartoon Edit menu and select Switch Positions. My Best Friend opens the Switch 
Positions dialogue showing miniatures of the frames.

2. In the dialogue click on one of the two frames you want to switch; it will change colour.

3. Then, click on the other frame.

4. The frames switch positions.

5. You can repeat this as many times as you like.

6. When you are finished, choose OK to confirm the new frame positions.



Launching Windows Application (Workshop Export or Export/Edit Menu)

Copies to the Clipboard what you are working on and starts the application that was last chosen with the Launch... 
command. (Note: no application is named under this menu until an application has been chosen the first time. Until then, 
you see only Windows Application.) Then you can paste the contents of the Clipboard into the application.

If a workspace is open My Best Friend copies only what is in the workspace to the Clipboard; otherwise, the entire cartoon 
strip is copied.

To launch a Windows application:

If one is not named:

1. Choose Windows Application under the Export or Export/Edit    menu to get a list of available 
Windows applications. Select the one you want and choose OK. Then continue with steps 2. to 5. 
below.

or

If one is named:

1. Choose the named application (e.g., PBRUSH) under the Export or Export/Edit menu. My Best 
Friend will start the application and switch you to it.

2. Choosing Paste under the Edit menu of the other application, you can transfer into it a copy of what 
you were working on in My Best Friend.

3. Now you can work with the picture in this application.

4. When you are finished, save your work and close the application.

5. You will return to My Best Friend .

See also:    Launch



Launch... (Workshop Export or Export/Edit    Menus)

starts the Launch dialogue to enable you to copy what you are working on in My Best Friend into another Windows 
application. My Best Friend then stores the name of the application you choose in the Windows Application option until 
another application is chosen.

To launch a Window application:

1: Choose Launch in the workshop menu.

2. Type the path and name of the application you want (.EXE extensions) into File Name, or click on the 
Search button and choose an EXE-file from the list that appears. Choose OK to confirm your choice.

3. In Name type the application name you want displayed under the Export and Export/Edit menu. If no 
name is typed, My Best Friend    uses the name on the EXE-file.

4. Choose OK to confirm your choices. My Best Friend starts the application you selected.



Workspace Options

Workspace Buttons
Writing in Text Containers
Moving Cartoons or Text Containers
Activating Cartoons or Text Containers



Workspace Buttons

You see workspace buttons when a workspace is open.    Cartoons or text containers have to be active (in a frame) in order
to use workspace buttons. Their appearance (that is, buttons colouring) shows whether they are active or not.

Click on a button to get more information about it.

 

 

 

 

 

 

 



Send to Back

Moves a cartoon to the layer closest to the background in the frame.



Flip Vertical

Flips the cartoon vertically.



Flip Horizontal

Flips the cartoon horizontally.



Make Bigger

Enlarges the cartoon.



Make Smaller

Reduces the cartoon.



Rotate

Turns the tail of the talk and thought text containers clockwise about 45° each time you click on the button.



Delete

Throws a text container or cartoon into the garbage can and activates the Undo button.



Undo

Retrieves what you have deleted.



Moving an Object (Cartoons or Text Containers) (Mouse Operation)

1. Click on the object you want to move and hold down the left mouse button.

2. A frame around the object shows you how big it is.

3. Holding down the left mouse button, drag the frame to another location. You still see the object in its old 
spot.

4. Release the mouse button when you have the frame positioned.

5. The object hops to the new location.

The object you moved continues to be active in its new location.



Text Containers and the Cartoon Library

In making your own cartoon strip, you use text containers and cartoon pictures.

You use text containers in both the Cartoon Strip and Cartoon Picture workshops, but you use the Cartoon Library only 
in the Cartoon Picture Workshop.

Text Container Buttons and the Cartoon Library appear on the right side of the screen.

Text Container Buttons
Cartoon Library
Getting the   Text Container Buttons   or the   Cartoon Library   (in the Cartoon Picture Workshop)



Getting Text Container Buttons or the Cartoon Library

In the Cartoon Picture Workshop you work with either text containers or the Cartoon Library.    

While the Text Container Buttons are displayed, the Cartoon Library is hidden and vice versa.

 These buttons display Text Container Buttons or the Cartoon Library. Only one of them is displayed at a time. Clicking 
on Text  will display Text Container Buttons, and clicking on Cartoons will display the Cartoon Library.

You can also choose Text    or Cartoons in the Export/Edit menu, Text/Cartoons.



Contents of the Cartoon Strip Library

The Cartoon Strip Library contains 40 cartoon strips, each with four cartoons.

The cartoon strips fall into four categories:

Sports:     8 strips
Home Life: 10 strips
Leisure: 11 strips
School: 11 strips

The main characters in the cartoon strips are the Girl, the Boy and their Pig.    In addition to these three, you will find 
many supporting characters: children, adults and a few animals.



Contents of the Cartoon Library

The Cartoon Library contains individual cartoons that you can use to make cartoon strips.

The Cartoon Library Menu offers the following options:

Backgrounds:
Scenes: 40 scenes
Colours: Colour palette and colour blending dialogue

People:
The Boy: 55 drawings
The Girl: 51 drawings
Others: 42 drawings

Animals:
The Pig: 19 drawings
Other animals: 20 drawings

Plants: 22 drawings

Things: 79 drawings



Workshops

A workshop provides you with tools you need to make stories in My Best Friend .

You have two kinds of    workshop in My Best Friend, one for Cartoon Strips and another for Cartoon Pictures. You 
open these workshops from the main menu by choosing Cartoon Strips or Cartoon Pictures.

You can also open a workshop by opening a story you have saved. My Best Friend opens the workshop you used to 
make the story. (For help on opening a story, see Open).

In Cartoon Strips and Cartoon Pictures there are four frames on the screen at a time and one set of tools (Text 
Container Buttons or the Cartoon Library).    You can put one frame at a time into the workspace to work on it.



Workspace

You work on frames for your story in a Workspace. There you can create pictures and write text for them.



There are three types of Text Container: 

Talk Container ,    Thought Container 

    and Text Strip 



You make an object active in a workspace by clicking on it with the left mouse button.

When a blinking cursor and a frame appear inside a text container, you know the container is active and ready for you to 
write in, rotate, delete or choose Undo using the workspace buttons.

A frame around a cartoon picture tells you the picture is active.    You can use workspace buttons on an active object.



Clipboard
The Clipboard stores whatever object was last Copied or Cut in a program. You copy or cut an object onto the Clipboard. 
Many other programs, like a word processor or a drawing program, enable you to place objects on the Clipboard and get 
them later with a command such as Paste.



Activating Cartoon Pictures or Text Containers

Click on cartoon pictures or text containers to make them active.



An object is either a cartoon picture or a text container that you have put in a workspace. 



Button colours show whether they are active or not.    Whether buttons are active depends on whether an active object is in
a workspace, and whether a button operation is appropriate for that object:

Active Button: 

Inactive Button: 



Contents

Displays the Contents of this Help.



Search for Help on...

Displays the search dialogue for Help.



How to Use Help

Displays instructions on how to use Windows Help.



About...

Displays information about My Best Friend , the publisher and authors.






